Data Processing Delays - Reporting Tools Affected

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 12:41 CEST

Update

We are continuing to investigate this issue.
Posted Mar 27, 2026 - 09:19 CET

Investigating

We are investigating a drop of sales and sales related metrics from March 25 18 UTC to March 26 17 UTC.
Posted Mar 26, 2026 - 16:58 CET
This incident affected: Commerce Max & Yield - UI (Analytics) and Commerce Max & Yield - API (Analytics).